]> git.mxchange.org Git - simgear.git/blob - package/openSUSE/SimGear.spec
Fallback for old Boost (also with UTF8-CPP library).
[simgear.git] / package / openSUSE / SimGear.spec
1 Summary:    Simulator Construction Gear
2 Name:       SimGear
3 Version:    2.8.0
4 Release:    1
5 License:    LGPL
6 URL:        http://www.flightgear.org
7 Group:      Amusements/Games/3D/Simulation
8 Source:     http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/simgear-%{version}.tar.bz2
9 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
10
11 BuildRequires: gcc, gcc-c++, cmake
12 BuildRequires: libopenal1-soft, openal-soft
13 BuildRequires: libOpenSceneGraph-devel >= 3.0
14 BuildRequires: zlib, zlib-devel
15 BuildRequires: libjpeg62, libjpeg62-devel
16 BuildRequires: boost-devel >= 1.37
17 BuildRequires: subversion-devel, libapr1-devel
18 Requires:      OpenSceneGraph-plugins >= 3.0
19
20 %description
21 This package contains a tools and libraries useful for constructing
22 simulation and visualization applications such as FlightGear or TerraGear.
23
24 %package devel
25 Group:         Development/Libraries/Other
26 Summary:       Development header files for SimGear
27 Requires:      SimGear = %{version}
28
29 %description devel
30 Development headers and libraries for building applications against SimGear.
31
32 %prep
33 %setup -T -q -n simgear-%{version} -b 0
34
35 %build
36 export CFLAGS="$RPM_OPT_FLAGS"
37 export CXXFLAGS="$RPM_OPT_FLAGS"
38 # build SHARED simgear libraries
39 cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} -DSIMGEAR_SHARED:BOOL=ON -DENABLE_TESTS:BOOL=OFF -DJPEG_FACTORY:BOOL=ON
40 make %{?_smp_mflags}
41
42 %install
43 make DESTDIR=%{buildroot} install
44
45 %post -p /sbin/ldconfig
46
47 %postun -p /sbin/ldconfig
48
49 %files
50 %defattr (-, root, root, -)
51 %doc AUTHORS COPYING ChangeLog NEWS README
52 %{_libdir}/libSimGear*.so.*
53
54 %files devel
55 %defattr(-,root,root,-)
56 %dir %{_includedir}/simgear
57 %{_includedir}/simgear/*
58 %{_libdir}/libSimGear*.so
59
60 %changelog
61 * Mon Jul 02 2012 thorstenb@flightgear.org
62 - Initial version
63