]> git.mxchange.org Git - simgear.git/blob - package/openSUSE/SimGear.spec
hla: Do not call time advance with non positive increment.
[simgear.git] / package / openSUSE / SimGear.spec
1 Summary:    Simulator Construction Gear
2 Name:       SimGear
3 Version:    2.8.0
4 Release:    1
5 License:    LGPL
6 URL:        http://www.flightgear.org
7 Group:      Amusements/Games/3D/Simulation
8 Source:     http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/simgear-%{version}.tar.bz2
9 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
10
11 BuildRequires: gcc, gcc-c++, cmake
12 BuildRequires: freealut, freealut-devel
13 BuildRequires: libopenal1-soft, openal-soft
14 BuildRequires: plib-devel >= 1.8.5
15 BuildRequires: libOpenSceneGraph-devel >= 3.0
16 BuildRequires: zlib, zlib-devel
17 BuildRequires: libjpeg62, libjpeg62-devel
18 BuildRequires: boost-devel >= 1.37
19 BuildRequires: subversion-devel, libapr1-devel
20 Requires:      OpenSceneGraph-plugins >= 3.0
21
22 %description
23 This package contains a tools and libraries useful for constructing
24 simulation and visualization applications such as FlightGear or TerraGear.
25
26 %package devel
27 Group:         Development/Libraries/Other
28 Summary:       Development header files for SimGear
29 Requires:      SimGear = %{version}
30 Requires:      plib-devel
31
32 %description devel
33 Development headers and libraries for building applications against SimGear.
34
35 %prep
36 %setup -T -q -n simgear-%{version} -b 0
37
38 %build
39 export CFLAGS="$RPM_OPT_FLAGS"
40 export CXXFLAGS="$RPM_OPT_FLAGS"
41 # build SHARED simgear libraries
42 cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} -DSIMGEAR_SHARED:BOOL=ON -DENABLE_TESTS:BOOL=OFF -DJPEG_FACTORY:BOOL=ON
43 make %{?_smp_mflags}
44
45 %install
46 make DESTDIR=%{buildroot} install
47
48 %post -p /sbin/ldconfig
49
50 %postun -p /sbin/ldconfig
51
52 %files
53 %defattr (-, root, root, -)
54 %doc AUTHORS COPYING ChangeLog NEWS README
55 %{_libdir}/libSimGear*.so.*
56
57 %files devel
58 %defattr(-,root,root,-)
59 %dir %{_includedir}/simgear
60 %{_includedir}/simgear/*
61 %{_libdir}/libSimGear*.so
62
63 %changelog
64 * Mon Jul 02 2012 thorstenb@flightgear.org
65 - Initial version
66