]> git.mxchange.org Git - quix0rs-gnu-social.git/blob - scripts/laconica.spec
Added the new pinghandler to the stopdaemons script and improved the behaviour and...
[quix0rs-gnu-social.git] / scripts / laconica.spec
1 BuildRequires:  php-pear
2 BuildRequires:  httpd-devel
3
4 Name:           laconica
5 Version:        0.7.2
6 Release:        1%{?dist}
7 License:        GAGPL v3 or later
8 Source:         laconica-0.7.2.tar.gz
9 Group:          Applications/Internet
10 Summary:        Laconica, the Open Source microblogging platform
11 BuildArch:      noarch
12
13 Requires:       httpd
14 Requires:       php >= 5
15 Requires:       php-pear-Mail-Mime
16 Requires:       php-curl
17 Requires:       php-mysql
18 Requires:       php-mbstring
19 Requires:       php-gettext
20 Requires:       php-xml
21 Requires:       php-gd
22
23 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
24
25 %define apache_serverroot %(/usr/sbin/apxs -q DATADIR)
26 %define apache_sysconfdir %(/usr/sbin/apxs -q SYSCONFDIR)
27 %define wwwpath %{apache_serverroot}/%{name}
28 %define confpath %{_sysconfdir}/%{name}
29
30 %description
31 From the ABOUT file: Laconica (pronounced "luh-KAWN-ih-kuh") is a Free
32 and Open Source microblogging platform. It helps people in a
33 community, company or group to exchange short (140 character) messages
34 over the Web. Users can choose which people to "follow" and receive
35 only their friends' or colleagues' status messages. It provides a
36 similar service to sites like Twitter, Jaiku, and Plurk. 
37
38
39 %prep
40 %setup -q
41
42 %build
43
44
45 %install
46 mkdir -p %{buildroot}%{wwwpath}
47 cp -a * %{buildroot}%{wwwpath}
48
49 mkdir -p %{buildroot}%{_datadir}/laconica
50 cp -a db %{buildroot}%{_datadir}/laconica/db
51
52 mkdir -p %{buildroot}%{_sysconfdir}/httpd/conf.d
53 cat > %{buildroot}%{_sysconfdir}/httpd/conf.d/laconica.conf <<"EOF"
54 Alias /laconica/ "/var/www/laconica/"
55
56 <Directory "/var/www/laconica">
57     Options Indexes FollowSymLinks
58     AllowOverride All
59     Order allow,deny
60     Allow from all
61 </Directory>
62 EOF
63
64 %clean
65 rm -rf %buildroot
66
67 %files
68 %defattr(-,root,root)
69 %dir %{wwwpath}
70 %{wwwpath}/*
71 %{_datadir}/laconica/*
72 %attr(-,apache,apache) %dir %{_datadir}/laconica/avatar
73 %doc COPYING README doc-src/*
74 %config(noreplace) %{_sysconfdir}/httpd/conf.d/laconica.conf
75
76 %changelog
77 * Wed Mar 03 2009 Zach Copley <zach@controlyourself.ca> - 0.7.2
78 - Changed version number to 0.7.2.
79
80 * Sat Feb 28 2009 Ken Sedgwick <ken@bonsai.com> - 0.7.1-1
81 - Modified RPM for Fedora.
82
83 * Thu Feb 13 2009 tuukka.pasanen@ilmi.fi
84 - packaged laconica version 0.7.1
85
86 * Wed Feb 04 2009 tuukka.pasanen@ilmi.fi
87 - packaged laconica version 0.7.0 using the buildservice spec file wizard