]> git.mxchange.org Git - quix0rs-gnu-social.git/blob - scripts/statusnet.spec
Merge branch '1.1.x' of gitorious.org:statusnet/mainline into 1.1.x
[quix0rs-gnu-social.git] / scripts / statusnet.spec
1 # This version needs to match the tarball and unpacked directory name.
2 %define LACVER 0.7.3
3
4 BuildRequires:  php-pear
5 BuildRequires:  httpd-devel
6
7 Name:           statusnet
8 Version:        %{LACVER}
9 Release:        1%{?dist}
10 License:        GAGPL v3 or later
11 Source:         statusnet-%{version}.tar.gz
12 Group:          Applications/Internet
13 Summary:        StatusNet, the Open Source microblogging platform
14 BuildArch:      noarch
15
16 Requires:       httpd
17 Requires:       php >= 5
18 Requires:       php-pear-Mail-Mime
19 Requires:       php-curl
20 Requires:       php-mysql
21 Requires:       php-mbstring
22 Requires:       php-gettext
23 Requires:       php-xml
24 Requires:       php-gd
25
26 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
27
28 %define apache_serverroot %(/usr/sbin/apxs -q DATADIR)
29 %define apache_sysconfdir %(/usr/sbin/apxs -q SYSCONFDIR)
30 %define wwwpath %{apache_serverroot}/%{name}
31 %define confpath %{_sysconfdir}/%{name}
32
33 %description
34 From the ABOUT file: StatusNet (pronounced "luh-KAWN-ih-kuh") is a Free
35 and Open Source microblogging platform. It helps people in a
36 community, company or group to exchange short (140 character) messages
37 over the Web. Users can choose which people to "follow" and receive
38 only their friends' or colleagues' status messages. It provides a
39 similar service to sites like Twitter, Jaiku, and Plurk. 
40
41
42 %prep
43 %setup -q
44
45 %build
46
47
48 %install
49 mkdir -p %{buildroot}%{wwwpath}
50 cp -a * %{buildroot}%{wwwpath}
51
52 mkdir -p %{buildroot}%{_datadir}/statusnet
53 cp -a db %{buildroot}%{_datadir}/statusnet/db
54
55 mkdir -p %{buildroot}%{_datadir}/statusnet/avatar
56
57 mkdir -p %{buildroot}%{_sysconfdir}/httpd/conf.d
58 cat > %{buildroot}%{_sysconfdir}/httpd/conf.d/statusnet.conf <<"EOF"
59 Alias /statusnet/ "/var/www/statusnet/"
60
61 <Directory "/var/www/statusnet">
62     Options Indexes FollowSymLinks
63     AllowOverride All
64     Order allow,deny
65     Allow from all
66 </Directory>
67 EOF
68
69 %clean
70 rm -rf %buildroot
71
72 %files
73 %defattr(-,root,root)
74 %dir %{wwwpath}
75 %{wwwpath}/*
76 %{_datadir}/statusnet/*
77 %attr(-,apache,apache) %dir %{_datadir}/statusnet/avatar
78 %doc COPYING README doc-src/*
79 %config(noreplace) %{_sysconfdir}/httpd/conf.d/statusnet.conf
80
81 %changelog
82 * Wed Apr 03 2009 Zach Copley <zach@status.net> - 0.7.3
83 - Changed version number to 0.7.3.
84
85 * Fri Mar 13 2009 Ken Sedgwick <ksedgwic@bonsai.com> - 0.7.2.1-1
86 - Factored statusnet version to the first line of the file.
87
88 * Wed Mar 03 2009 Zach Copley <zach@status.net> - 0.7.2
89 - Changed version number to 0.7.2.
90
91 * Sat Feb 28 2009 Ken Sedgwick <ken@bonsai.com> - 0.7.1-1
92 - Modified RPM for Fedora.
93
94 * Thu Feb 13 2009 tuukka.pasanen@ilmi.fi
95 - packaged statusnet version 0.7.1
96
97 * Wed Feb 04 2009 tuukka.pasanen@ilmi.fi
98 - packaged statusnet version 0.7.0 using the buildservice spec file wizard