Rewrote all TODO lines, 'hooks.php' is now fully deprecated and emptied
[core.git] / inc / includes.php
index 0174a4a..122ce18 100644 (file)
@@ -8,7 +8,7 @@
  * @license            GNU GPL 3.0 or any newer version
  * @link               http://www.ship-simu.org
  * @deprecated
- * @todo               We should minimize these includes
+ * @todo               Minimize these includes
  *
  * This program is free software: you can redistribute it and/or modify
  * it under the terms of the GNU General Public License as published by
@@ -31,8 +31,9 @@ require(FrameworkConfiguration::getSelfInstance()->getConfigEntry('base_path') .
 // Load matching config
 ClassLoader::getSelfInstance()->loadExtraConfigs();
 
-// Register hooks here
-require(FrameworkConfiguration::getSelfInstance()->getConfigEntry('base_path') . 'inc/hooks.php');
+// Register auto-load function with the SPL
+// @TODO This makes the core depending on the SPL. But it should be installed anyway.
+spl_autoload_register('ClassLoader::autoLoad');
 
 // Does the user has an application specified?
 // @TODO Find a nicer OOP-ed way for this