- obsolete templates/scripts removed
[mailer.git] / 0.2.1 / confirm.php
index 9470339..9d18c11 100644 (file)
@@ -37,8 +37,8 @@ require_once("inc/libs/security_functions.php");
 // Init "action" and "what"\r
 global $what, $action;\r
 $GLOBALS['what'] = ""; $GLOBALS['action'] = "";\r
-if (!empty($_GET['action'])) $GLOBALS['action'] = trim(strip_tags($_GET['action']));\r
-if (!empty($_GET['what'])) $GLOBALS['what'] = trim(strip_tags($_GET['what']));\r
+if (!empty($_GET['action'])) $GLOBALS['action'] = secureString($_GET['action']);\r
+if (!empty($_GET['what'])) $GLOBALS['what'] = secureString($_GET['what']);\r
 \r
 // Set module to confirm\r
 $GLOBALS['module'] = "confirm"; $CSS = -1;\r