Fix for the fix... ;-)
[mailer.git] / inc / mysql-connect.php
index 600eae1..467f218 100644 (file)
@@ -49,6 +49,11 @@ require_once(PATH."inc/db/lib.php");
 
 // Load general functions
 require_once(PATH."inc/functions.php");  // Non-database functions
+
+// Load more include files
+require_once(PATH."inc/mysql-manager.php"); // Functions which interact with the database
+
+// Load extensions and language
 require_once(PATH."inc/extensions.php");
 require_once(PATH."inc/language.php");
 
@@ -69,7 +74,7 @@ if ((empty($MySQL['login'])) && (!defined('mxchange_installing')) && (!isset($_G
 }
 
 // Check if this file is writeable or read-only and warn the user
-if ((!defined('mxchange_installing')) && (isBooleanConstantAndTrue('mxchange_installed'))) {
+if ((!isBooleanConstantAndTrue('mxchange_installing')) && (isBooleanConstantAndTrue('mxchange_installed'))) {
        // Check for write-permission for config.php and inc directory
        if (empty($GLOBALS['module'])) $GLOBALS['module'] = "index";
        if (($GLOBALS['module'] != "admin") && (isBooleanConstantAndTrue('admin_registered')) && (!isset($_SERVER['WINDIR']))) {
@@ -91,9 +96,6 @@ if ((!defined('mxchange_installing')) && (isBooleanConstantAndTrue('mxchange_ins
 
                        // Is it a valid resource?
                        if ($db === true) {
-                               // Load more include files
-                               require_once(PATH."inc/mysql-manager.php"); // Functions which interact with the database
-
                                // Load configuration stuff
                                $_CONFIG = LOAD_CONFIG();