Removed double-update (0.2.1) for ext-doubler as it caused SQL error (which needs...
authorRoland Häder <roland@mxchange.org>
Fri, 31 May 2013 08:01:39 +0000 (08:01 +0000)
committerRoland Häder <roland@mxchange.org>
Fri, 31 May 2013 08:01:39 +0000 (08:01 +0000)
inc/extensions/doubler/mode-update.php
inc/extensions/ext-doubler.php

index da3cb46..b85eb70 100644 (file)
@@ -41,6 +41,7 @@ if (!defined('__SECURITY')) {
 } // END - if
 
 // @TODO Remove double tabs from all lines
+               switch (getCurrentExtensionVersion()) {
                        case '0.0.1': // SQL queries for v0.0.1
                                // Update notes (these will be set as task text!)
                                setExtensionUpdateNotes("Problem mit Mitglieds-Id behoben.");
@@ -165,15 +166,6 @@ if (!defined('__SECURITY')) {
                                // Update notes (these will be set as task text!)
                                setExtensionUpdateNotes("Filter zum Ausschlie&szlig;en des konfigurierten Mitgliedaccounts.");
                                break;
-
-                       case '0.2.1': // SQL queries for v0.2.1
-                               // Register subject lines
-                               registerExtensionPointsData('doubler_direct', 'points', 'LOCKED', 'DIRECT');
-                               registerExtensionPointsData('doubler_reset', 'points', 'LOCKED', 'DIRECT');
-
-                               // Update notes (these will be set as task text!)
-                               setExtensionUpdateNotes("Verwendungszwecks f&uuml;r Guthabenkonten hinzugef&uuml;gt.");
-                               break;
                } // END - switch
 
 // [EOF]
index b0cedb8..eac8bde 100644 (file)
@@ -41,10 +41,10 @@ if (!defined('__SECURITY')) {
 } // END - if
 
 // Version number
-setThisExtensionVersion('0.2.1');
+setThisExtensionVersion('0.2.0');
 
 // Version history array (add more with , '0.0.1' and so on)
-setExtensionVersionHistory(array('0.0.0', '0.0.1', '0.0.2', '0.0.3', '0.0.4', '0.0.5', '0.0.6', '0.0.7', '0.0.8', '0.0.9', '0.1.0', '0.1.1', '0.1.2', '0.1.3', '0.1.4', '0.1.5', '0.1.6', '0.1.7', '0.1.8', '0.1.9', '0.2.0', '0.2.1'));
+setExtensionVersionHistory(array('0.0.0', '0.0.1', '0.0.2', '0.0.3', '0.0.4', '0.0.5', '0.0.6', '0.0.7', '0.0.8', '0.0.9', '0.1.0', '0.1.1', '0.1.2', '0.1.3', '0.1.4', '0.1.5', '0.1.6', '0.1.7', '0.1.8', '0.1.9', '0.2.0'));
 
 switch (getExtensionMode()) {
        case 'setup': // Do stuff when installation is running