Better check for PHP version in setMagicQuotesRuntime() as set_magic_quotes_runtime...
authorRoland Häder <roland@mxchange.org>
Thu, 18 Jul 2013 12:22:00 +0000 (12:22 +0000)
committerRoland Häder <roland@mxchange.org>
Thu, 18 Jul 2013 12:22:00 +0000 (12:22 +0000)
inc/config/class_FrameworkConfiguration.php

index 6e8758d..81ac582 100644 (file)
@@ -97,8 +97,12 @@ class FrameworkConfiguration implements Registerable {
         * @return      void
         */
        public final function setDefaultTimezone ($zone) {
-               // At least 5.1.0 is required for this!
-               if (version_compare(phpversion(), '5.1.0')) {
+               // Is PHP version 5.1.0 or higher? Older versions are being ignored
+               if (version_compare(phpversion(), '5.1.0', '>=')) {
+                       /*
+                        * Set desired time zone to prevent date() and related functions to
+                        * issue a E_WARNING.
+                        */
                        date_default_timezone_set($zone);
                } // END - if
        }
@@ -108,8 +112,15 @@ class FrameworkConfiguration implements Registerable {
         *
         * @param       $enableQuotes   Whether enable magic runtime quotes (should be disabled for security reasons)
         * @return      void
+        * @todo        This method encapsulates a deprecated PHP function and should be deprecated, too.
         */
        public final function setMagicQuotesRuntime ($enableQuotes) {
+               // Is the PHP version < 5.4?
+               if (version_compare(phpversion(), '5.4', '>=')) {
+                       // Then silently skip this part as set_magic_quotes_runtime() is deprecated
+                       return;
+               } // END - if
+
                // Cast it to boolean
                $enableQuotes = (boolean) $enableQuotes;