generateHash() does now hash with md5() if sql_patches is missing or out-dated
authorRoland Häder <roland@mxchange.org>
Sun, 9 Nov 2008 21:57:12 +0000 (21:57 +0000)
committerRoland Häder <roland@mxchange.org>
Sun, 9 Nov 2008 21:57:12 +0000 (21:57 +0000)
inc/databases.php
inc/functions.php

index dd23915..2b16fbd 100644 (file)
@@ -114,7 +114,7 @@ define('USAGE_BASE', "usage");
 define('SERVER_URL', "http://www.mxchange.org");
 
 // This current patch level
-define('CURR_SVN_REVISION', "528");
+define('CURR_SVN_REVISION', "529");
 
 // Take a prime number which is long (if you know a longer one please try it out!)
 define('_PRIME', 591623);
index df47862..64d80b0 100644 (file)
@@ -1981,8 +1981,8 @@ function generateHash ($plainText, $salt = "") {
 
        // Is the required extension "sql_patches" there and a salt is not given?
        if (((EXT_VERSION_IS_OLDER("sql_patches", "0.3.6")) || (!EXT_IS_ACTIVE("sql_patches"))) && (empty($salt))) {
-               // Extension sql_patches is missing/outdated so we return the plain text
-               return $plainText;
+               // Extension sql_patches is missing/outdated so we hash the plain text with MD5
+               return md5($plainText);
        } // END - if
 
        // Do we miss an arry element here?